#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(([0-1][0-9])|([2][0-3])):([0-5][0-9])(:([0-5][0-9]))?([.]\d{3})?$"
Local $sString = "23:59" & @CRLF & _
"23:59:30" & @CRLF & _
"23:59:34.123" & @CRLF & _
"23:59:12" & @CRLF & _
"23:60" & @CRLF & _
"23:59." & @CRLF & _
"23:59.60"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)