package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(([0-1][0-9])|([2][0-3])):([0-5][0-9])(:([0-5][0-9]))?([.]\d{3})?$`)
var str = `23:59
23:59:30
23:59:34.123
23:59:12
23:60
23:59.
23:59.60`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}