import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=.*[A-Z])\n"
+ "(?=.*[a-z])\n"
+ "(?=.*[0-9])\n"
+ "(?!.*[<>`])\n"
+ "(?=[^.,:;'!@#$%^&*_+=|()\\{\\}[?\\-\\]\\/\\\\]*\n"
+ " [.,:;'!@#$%^&*_+=|()\\{\\}[?\\-\\]\\/\\\\]\n"
+ " [^.,:;'!@#$%^&*_+=|()\\{\\}[?\\-\\]\\/\\\\]*$\n"
+ ")\n"
+ ".{8}$";
final String string = "Aa1;;aaa\n"
+ "1aD15fs!";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}