re = /(?=.*[A-Z])
(?=.*[a-z])
(?=.*[0-9])
(?!.*[<>`])
(?=[^.,:;'!@#$%^&*_+=|(){}[?\-\]\/\\]*
[.,:;'!@#$%^&*_+=|(){}[?\-\]\/\\]
[^.,:;'!@#$%^&*_+=|(){}[?\-\]\/\\]*$
)
.{8}$/mx
str = 'Aa1;;aaa
1aD15fs!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end