#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[^\d]([\d]{5})[^\d]|[^\d]([\d]{13})[^\d]"
Local $sString = " ABC 54 SOMETHING 11165 POP 1234567890" & @CRLF & _
"SOMETHING ABC/W 05/1234500022385" & @CRLF & _
"SomethingW1234500006840Abc05 d 13/1/15"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")