re = /[^\d]([\d]{5})[^\d]|[^\d]([\d]{13})[^\d]/
str = ' ABC 54 SOMETHING 11165 POP 1234567890
SOMETHING ABC/W 05/1234500022385
SomethingW1234500006840Abc05 d 13/1/15'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end