package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^\d]([\d]{5})[^\d]|[^\d]([\d]{13})[^\d]`)
var str = ` ABC 54 SOMETHING 11165 POP 1234567890
SOMETHING ABC/W 05/1234500022385
SomethingW1234500006840Abc05 d 13/1/15`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}