const regex = /[^\d]([\d]{5})[^\d]|[^\d]([\d]{13})[^\d]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\d]([\\d]{5})[^\\d]|[^\\d]([\\d]{13})[^\\d]', 'g')
const str = ` ABC 54 SOMETHING 11165 POP 1234567890
SOMETHING ABC/W 05/1234500022385
SomethingW1234500006840Abc05 d 13/1/15`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}