#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "((?<!\p{L})(?=\d(?=(?:[- _]*\d){3,4}(?!\p{L})))|(?!^)\G)[- _]?\d(?!\d*\p{L})"
Local $sString = ""0000" will become "****"" & @CRLF & _
""any text 000 00 more texts" will become "any text ***** more texts"..notice that the space is removed" & @CRLF & _
""any text 000 00 more texts 00" will become "any text ***** more texts 00"" & @CRLF & _
"" & @CRLF & _
""any text 000 00 more texts 00 00" will become "any text ***** more texts ****"" & @CRLF & _
"" & @CRLF & _
""any text 00-00 more texts 00_00" will become "any text **** more texts ****""
Local $sSubst = "*"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)