import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?<!\\p{L})(?=\\d(?=(?:[- _]*\\d){3,4}(?!\\p{L})))|(?!^)\\G)[- _]?\\d(?!\\d*\\p{L})";
final String string = "\"0000\" will become \"****\"\n"
+ "\"any text 000 00 more texts\" will become \"any text ***** more texts\"..notice that the space is removed\n"
+ "\"any text 000 00 more texts 00\" will become \"any text ***** more texts 00\"\n\n"
+ "\"any text 000 00 more texts 00 00\" will become \"any text ***** more texts ****\"\n\n"
+ "\"any text 00-00 more texts 00_00\" will become \"any text **** more texts ****\"";
final String subst = "*";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}