using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?<!\p{L})(?=\d(?=(?:[- _]*\d){3,4}(?!\p{L})))|(?!^)\G)[- _]?\d(?!\d*\p{L})";
string substitution = @"*";
string input = @"""0000"" will become ""****""
""any text 000 00 more texts"" will become ""any text ***** more texts""..notice that the space is removed
""any text 000 00 more texts 00"" will become ""any text ***** more texts 00""
""any text 000 00 more texts 00 00"" will become ""any text ***** more texts ****""
""any text 00-00 more texts 00_00"" will become ""any text **** more texts ****""";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}