use strict;
my $str = 'fdsfsdfd2020-01racts_csvSGR-1_NFU.csv';
my $regex = qr/(\d{4})-(\d{2})/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";