re = /(\d{4})-(\d{2})/
str = 'fdsfsdfd2020-01racts_csvSGR-1_NFU.csv'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result