$re = '/(\d{4})-(\d{2})/';
$str = 'fdsfsdfd2020-01racts_csvSGR-1_NFU.csv';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;