import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([+]|00|0$)(\\d*)$";
final String string = "+\n"
+ "0\n"
+ "+123\n"
+ "00\n"
+ "0032476382763\n"
+ "+324763\n\n"
+ "01\n"
+ "++\n"
+ "3434";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}