$re = '/^([+]|00|0$)(\d*)$/ms';
$str = '+
0
+123
00
0032476382763
+324763
01
++
3434';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);