using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"-?\d+(\s?[\+\-\*\/]\s?-?\d)+";
string input = @"something something nothing 1/ 2 * 3 nothing hello world
something something nothing 1 / 2 * 3 nothing hello world
something something nothing 1/ 2 nothing hello world
something something nothing 1/ 2 * 3 - 4 nothing hello world
something something nothing 1/ 2 * (3 - 4) nothing hello world";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}