import re
regex = re.compile(r"-?\d+(\s?[\+\-\*\/]\s?-?\d)+")
test_str = ("something something nothing 1/ 2 * 3 nothing hello world\n"
"something something nothing 1 / 2 * 3 nothing hello world\n"
"something something nothing 1/ 2 nothing hello world\n"
"something something nothing 1/ 2 * 3 - 4 nothing hello world\n"
"something something nothing 1/ 2 * (3 - 4) nothing hello world")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")