import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "-?\\d+(\\s?[\\+\\-\\*\\/]\\s?-?\\d)+";
final String string = "something something nothing 1/ 2 * 3 nothing hello world\n"
+ "something something nothing 1 / 2 * 3 nothing hello world\n"
+ "something something nothing 1/ 2 nothing hello world\n"
+ "something something nothing 1/ 2 * 3 - 4 nothing hello world\n"
+ "something something nothing 1/ 2 * (3 - 4) nothing hello world";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}