$re = '/-?\d+(\s?[\+\-\*\/]\s?-?\d)+/';
$str = 'something something nothing 1/ 2 * 3 nothing hello world
something something nothing 1 / 2 * 3 nothing hello world
something something nothing 1/ 2 nothing hello world
something something nothing 1/ 2 * 3 - 4 nothing hello world
something something nothing 1/ 2 * (3 - 4) nothing hello world';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);