using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(~|^)([^~]*?ABCD.*?#.*?)(~|$)";
string input = @"fshjk#3~dhaj#NON-LOCAL~dhahdate#64030~kjqiwDATE2#64030`75:~kwokdNUM#000000010652~ncdj#158672694~pwkd#410~djakj#147~xkiww#322285781~lowqABCD#1025133646~jdoi#~pwdljae#25133648~pqeidjdt#04212016";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}