const regex = /(~|^)([^~]*?ABCD.*?#.*?)(~|$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(~|^)([^~]*?ABCD.*?#.*?)(~|$)', 'g')
const str = `fshjk#3~dhaj#NON-LOCAL~dhahdate#64030~kjqiwDATE2#64030\`75:~kwokdNUM#000000010652~ncdj#158672694~pwkd#410~djakj#147~xkiww#322285781~lowqABCD#1025133646~jdoi#~pwdljae#25133648~pqeidjdt#04212016`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}