re = /(~|^)([^~]*?ABCD.*?#.*?)(~|$)/
str = 'fshjk#3~dhaj#NON-LOCAL~dhahdate#64030~kjqiwDATE2#64030`75:~kwokdNUM#000000010652~ncdj#158672694~pwkd#410~djakj#147~xkiww#322285781~lowqABCD#1025133646~jdoi#~pwdljae#25133648~pqeidjdt#04212016'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end