// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(~|^)([^~]*?ABCD.*?#.*?)(~|$)").unwrap();
let string = "fshjk#3~dhaj#NON-LOCAL~dhahdate#64030~kjqiwDATE2#64030`75:~kwokdNUM#000000010652~ncdj#158672694~pwkd#410~djakj#147~xkiww#322285781~lowqABCD#1025133646~jdoi#~pwdljae#25133648~pqeidjdt#04212016";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}