import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=<title>|(?!^)\\G).*?\\K(Машины|Маша)(?=(?:.(?!<title>))*?<\\/title>)";
final String string = "Маша <title>Машины волосы мягкие и шелковистые потому что Маша пользуется Head & Shoulders</title>\n\n"
+ "Маша уже 10 лет пользуется Head & Shoulders и она очень довольна.\n\n"
+ "<!-- А это еще один title в конце документа -->\n\n"
+ "<title>Машины волосы мягкие и шелковистые потому что Маша пользуется Head & Shoulders</title>";
final String subst = "***";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.UNICODE_CASE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}