re = /(?<=<title>|(?!^)\G).*?\K(Машины|Маша)(?=(?:.(?!<title>))*?<\/title>)/i
str = 'Маша <title>Машины волосы мягкие и шелковистые потому что Маша пользуется Head & Shoulders</title>
Маша уже 10 лет пользуется Head & Shoulders и она очень довольна.
<!-- А это еще один title в конце документа -->
<title>Машины волосы мягкие и шелковистые потому что Маша пользуется Head & Shoulders</title>'
subst = '***'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result