# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=<title>|(?!^)\G).*?\K(Машины|Маша)(?=(?:.(?!<title>))*?<\/title>)"
test_str = ("Маша <title>Машины волосы мягкие и шелковистые потому что Маша пользуется Head & Shoulders</title>\n\n"
"Маша уже 10 лет пользуется Head & Shoulders и она очень довольна.\n\n"
"<!-- А это еще один title в конце документа -->\n\n"
"<title>Машины волосы мягкие и шелковистые потому что Маша пользуется Head & Shoulders</title>")
subst = "***"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE | re.UNICODE | re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.