#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<!\n) *\n(?=[^\n])"
Local $sString = "Featuring six amazing National Parks: Glacier," & @CRLF & _
"Waterton Lakes, Yellowstone, Grand Teton, Arches, and Canyonlands." & @CRLF & _
"" & @CRLF & _
"Your tour begins in Chicago where you will board" & @CRLF & _
"the Empire Builder" & @CRLF & _
"bound for the first National Park on your trip, Glacier, where you will explore the famed Going-to-the-Sun Road and enjoy a full-day excursion to" & @CRLF & _
"Waterton Lakes National Park in Canada (passport required)."
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)