import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\n) *\\n(?=[^\\n])";
final String string = "Featuring six amazing National Parks: Glacier,\n"
+ "Waterton Lakes, Yellowstone, Grand Teton, Arches, and Canyonlands.\n\n"
+ "Your tour begins in Chicago where you will board\n"
+ "the Empire Builder\n"
+ "bound for the first National Park on your trip, Glacier, where you will explore the famed Going-to-the-Sun Road and enjoy a full-day excursion to\n"
+ "Waterton Lakes National Park in Canada (passport required).";
final String subst = " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}