# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!\n) *\n(?=[^\n])"
test_str = ("Featuring six amazing National Parks: Glacier,\n"
"Waterton Lakes, Yellowstone, Grand Teton, Arches, and Canyonlands.\n\n"
"Your tour begins in Chicago where you will board\n"
"the Empire Builder\n"
"bound for the first National Park on your trip, Glacier, where you will explore the famed Going-to-the-Sun Road and enjoy a full-day excursion to\n"
"Waterton Lakes National Park in Canada (passport required).")
subst = " "
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.