# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*("score":[-+]?\d*\.?\d+).*/$1/g;t' <<< "{\"score\":0,\"compare\":0,\"words\":[\"book\",\"planet\",\"sun\",\"science\"],\"words\":[],\"good\":[],\"bad\":[]}
{\"score\":-1,\"compare\":0,\"words\":[\"book\",\"planet\",\"sun\",\"science\"],\"words\":[],\"good\":[],\"bad\":[]}
{\"score\":1,\"compare\":0,\"words\":[\"book\",\"planet\",\"sun\",\"science\"],\"words\":[],\"good\":[],\"bad\":[]}"