package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*("score":[-+]?\d*\.?\d+).*`)
var str = `{"score":0,"compare":0,"words":["book","planet","sun","science"],"words":[],"good":[],"bad":[]}
{"score":-1,"compare":0,"words":["book","planet","sun","science"],"words":[],"good":[],"bad":[]}
{"score":1,"compare":0,"words":["book","planet","sun","science"],"words":[],"good":[],"bad":[]}`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}