#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ".*("score":[-+]?\d*\.?\d+).*"
Local $sString = "{"score":0,"compare":0,"words":["book","planet","sun","science"],"words":[],"good":[],"bad":[]}" & @CRLF & _
"{"score":-1,"compare":0,"words":["book","planet","sun","science"],"words":[],"good":[],"bad":[]}" & @CRLF & _
"{"score":1,"compare":0,"words":["book","planet","sun","science"],"words":[],"good":[],"bad":[]}"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)