// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#".*("score":[-+]?\d*\.?\d+).*"#).unwrap();
let string = "{\"score\":0,\"compare\":0,\"words\":[\"book\",\"planet\",\"sun\",\"science\"],\"words\":[],\"good\":[],\"bad\":[]}
{\"score\":-1,\"compare\":0,\"words\":[\"book\",\"planet\",\"sun\",\"science\"],\"words\":[],\"good\":[],\"bad\":[]}
{\"score\":1,\"compare\":0,\"words\":[\"book\",\"planet\",\"sun\",\"science\"],\"words\":[],\"good\":[],\"bad\":[]}";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}