using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^";
string input = @"567* hELLO 565 ^this is >>>>> a special ads special sy3mbol || 999999* fgdg";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}