re = /^/
str = '567* hELLO 565 ^this is >>>>> a special ads special sy3mbol || 999999* fgdg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end