re = /[\W\S]{0,64}bit\S?so[\W\S]{0,64}/i
str = 'api = new Bitso(\'AFJHFF\', \'42376tfddd662\')
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end