#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(HEALTHCHECK)(((?:\s*\\?\s*)--\w+=\w+(?:\s*\\?\s*))*)"
Local $sString = "FROM golang as build" & @CRLF & _
"" & @CRLF & _
"RUN apt-get install wget curl && \" & @CRLF & _
" wget https://github.com/watchexec/watchexec/releases/download/v1.24.2/watchexec-1.24.2-x86_64-unknown-linux-gnu.deb && \" & @CRLF & _
" dpkg -i watchexec-1.24.2-x86_64-unknown-linux-gnu.deb && \" & @CRLF & _
" rm watchexec-1.24.2-x86_64-unknown-linux-gnu.deb" & @CRLF & _
"" & @CRLF & _
"ENV REPOSITORY_ROOT="/repositories"" & @CRLF & _
"ENV TEMPLATE_DIR="/api/templates"" & @CRLF & _
"ENV STATIC_DIR="/api/static"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"WORKDIR /api/src" & @CRLF & _
"RUN mkdir /.cache && chmod 0777 /.cache" & @CRLF & _
"" & @CRLF & _
"HEALTHCHECK --interval=10s --timeout=10s --retries=3 CMD curl http://localhost:3333/sign-in" & @CRLF & _
"" & @CRLF & _
"USER 1234:1234" & @CRLF & _
"ENTRYPOINT ["watchexec", "-r", "-w", "/api", "go", "run", "."]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")