package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(HEALTHCHECK)(((?:\s*\\?\s*)--\w+=\w+(?:\s*\\?\s*))*)`)
var str = `FROM golang as build
RUN apt-get install wget curl && \
wget https://github.com/watchexec/watchexec/releases/download/v1.24.2/watchexec-1.24.2-x86_64-unknown-linux-gnu.deb && \
dpkg -i watchexec-1.24.2-x86_64-unknown-linux-gnu.deb && \
rm watchexec-1.24.2-x86_64-unknown-linux-gnu.deb
ENV REPOSITORY_ROOT="/repositories"
ENV TEMPLATE_DIR="/api/templates"
ENV STATIC_DIR="/api/static"
WORKDIR /api/src
RUN mkdir /.cache && chmod 0777 /.cache
HEALTHCHECK --interval=10s --timeout=10s --retries=3 CMD curl http://localhost:3333/sign-in
USER 1234:1234
ENTRYPOINT ["watchexec", "-r", "-w", "/api", "go", "run", "."]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}