$re = '`(HEALTHCHECK)(((?:\s*\\\\?\s*)--\w+=\w+(?:\s*\\\\?\s*))*)`m';
$str = 'FROM golang as build
RUN apt-get install wget curl && \\
wget https://github.com/watchexec/watchexec/releases/download/v1.24.2/watchexec-1.24.2-x86_64-unknown-linux-gnu.deb && \\
dpkg -i watchexec-1.24.2-x86_64-unknown-linux-gnu.deb && \\
rm watchexec-1.24.2-x86_64-unknown-linux-gnu.deb
ENV REPOSITORY_ROOT="/repositories"
ENV TEMPLATE_DIR="/api/templates"
ENV STATIC_DIR="/api/static"
WORKDIR /api/src
RUN mkdir /.cache && chmod 0777 /.cache
HEALTHCHECK --interval=10s --timeout=10s --retries=3 CMD curl http://localhost:3333/sign-in
USER 1234:1234
ENTRYPOINT ["watchexec", "-r", "-w", "/api", "go", "run", "."]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);