const regex = new RegExp('(HEALTHCHECK)(((?:\\s*\\\\?\\s*)--\\w+=\\w+(?:\\s*\\\\?\\s*))*)', 'gm')
const str = `FROM golang as build
RUN apt-get install wget curl && \\
wget https://github.com/watchexec/watchexec/releases/download/v1.24.2/watchexec-1.24.2-x86_64-unknown-linux-gnu.deb && \\
dpkg -i watchexec-1.24.2-x86_64-unknown-linux-gnu.deb && \\
rm watchexec-1.24.2-x86_64-unknown-linux-gnu.deb
ENV REPOSITORY_ROOT="/repositories"
ENV TEMPLATE_DIR="/api/templates"
ENV STATIC_DIR="/api/static"
WORKDIR /api/src
RUN mkdir /.cache && chmod 0777 /.cache
HEALTHCHECK --interval=10s --timeout=10s --retries=3 CMD curl http://localhost:3333/sign-in
USER 1234:1234
ENTRYPOINT ["watchexec", "-r", "-w", "/api", "go", "run", "."]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}