using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\\r(?!\\n)|(?<!\\r)\\n|\\[^rn]";
string input = @"End Time Zone: 6/6/2024 10:00:00 PM in (UTC+08:00) South Indonesia, Singapore\n";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}