import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\\r(?!\\\\n)|(?<!\\\\r)\\\\n|\\\\[^rn]";
final String string = "End Time Zone: 6/6/2024 10:00:00 PM in (UTC+08:00) South Indonesia, Singapore\\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}