re = /\\r(?!\\n)|(?<!\\r)\\n|\\[^rn]/
str = 'End Time Zone: 6/6/2024 10:00:00 PM in (UTC+08:00) South Indonesia, Singapore\\n'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end