const regex = /\\r(?!\\n)|(?<!\\r)\\n|\\[^rn]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\\r(?!\\\\n)|(?<!\\\\r)\\\\n|\\\\[^rn]', 'g')
const str = `End Time Zone: 6/6/2024 10:00:00 PM in (UTC+08:00) South Indonesia, Singapore\\n`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}