#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(^$|^(https?://)?(?!.*\s)[\da-z.-]+\.([a-z.]{2,6})([/\w .-]*))" & @CRLF & _
"" & @CRLF & _
""
Local $sString = "wewe.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")