$re = '/(^$|^(https?://)?(?!.*\s)[\da-z.-]+\.([a-z.]{2,6})([/\w .-]*))
/';
$str = 'wewe.com';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);