re = /(^$|^(https?:\/\/)?(?!.*\s)[\da-z.-]+\.([a-z.]{2,6})([\/\w .-]*))
/
str = 'wewe.com'
# Print the match result
str.match(re) do |match|
puts match.to_s
end