using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^$|^(https?://)?(?!.*\s)[\da-z.-]+\.([a-z.]{2,6})([/\w .-]*))
";
string input = @"wewe.com";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}