using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @",(?![^()]*\))";
string substitution = @"\n";
string input = @"K.VisueelNr,IFNULL(P.Partijnaam, 'Leeg gemeld')";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}